in reply to this object

I tried to stop / from using the socket of because of a bug in Debian that renders the audio daemons useless after some time: sockets do not get closed and the only way to get audio back when there are no sockets left is to restart.

The way I tried to do it didn't work completely. still opens sockets to the pulseaudio daemon - even though the processes show that they run in an environment containing PULSE-SERVER=unix:/dev/null.

Any ideas how I stop firefox using that pulseaudio socket? Mount namespace - does it include sockets? A restriction on a systemd slice (cgroup) I could use?

in reply to this object

That looks really great! Can't wait see it filled with life.

Meanwhile I'll share my solution. I'm an user since more than 30 years and I'm running my own email server since nearly the start of it.

The lack of having a reliable email client for my , my sons and in general bothered me a long time. didn't fit my needs and which I use on my desktop is no option for mobile devices, yet.

I ended up using to access a .

I intentionally broke audio output of and :

Lately I found that I'd sometimes like to click on audio content people are sharing. I do and somehow expectedly I can't hear what Firefox starts playing.

Found OpenWith which allows to open an URL through its context menu with any configured external program.

Now I can open links to a lot of content by using FreeTube.

in reply to this object

Sometimes listening isn't enough. Had to go into a video conference yesterday. Listening to music on my worked fine, but when I tried to get audio in the conference I remembered that my desktop is broken, because of this issue I wrote about.

I had to ask the other participants to wait, because I'd need to restart my desktop to get sound. Not funny if connected with people partly working on Apple devices.

time: the major problem at the time being in my use case seems to be and leaving sockets to pipewire- open.

I now run them using PULSE-SERVER=unix:/dev/null <program> and it seems they really do not connect to pipewire-pulse anymore and therefor can't leave its sockets open.

No sound in apps is o.k. - I can always run - if I need a page deliver sound.