Story is probably not new: using a (linux mobile) and everybody insists on using WhatsApp. I didn't care. But all activities the kids want to take part: .

I could try to evangelize all these football trainers, parents representatives at schools, parents of friends to use something that I'm able to use on my linux phone, but I can't: lack of energy, lack of time, lack of alternatives with the same feature set and stability.

Got out an old Sony Z1 running . Really old software. Got an so far unused SIM. I used Aurora Store from F-Droid to install WhatsApp from the Google Store on that Android. Registered to WhatsApp and it worked fine sending one test message that never arrived, because the other side didn't have my phone number in their contacts (I guess).

I installed as a server on my and put mautrix-whatsapp on its own system using the latest docker image following the documentation to get a minimum configuration running.

Yeah, works. Coupled WhatsApp on the Android Z1 with the bridge and send two test messages resulting in This account can no longer use WhatsApp due to spam shown on the device.

Is that most likely because of my 10+ years device + rooted + Magisk + fake google app store or is it something others are experiencing when trying to use the bridge with of the shelf devices, too?

My plan has been to run an independent phone number for WhatsApp on a device that only has contacts for WhatsApp in its phone book and make it available to family members through matrix.

Our participation in society relies in many aspects on the goodwill of a few monopolistic companies that we depend on. They write the rules which device (Android or iOS) and which software (only their own doing whatever they program it to do) we're supposed to use. They train the algorithms that can cut you off our participation.

I wouldn't care the least. I'd even smile when reading this thinking that it's exactly what people supporting companies like facebook/whatsapp deserve. But if the participation of my kids in society is at stake (and not my own which I well can organize without any messenger) it makes me sad.

Just to mention it:

Updated a Sony Z3c running and upgraded a tablet running . Thanks for all the people who build these systems!

It took me about two hours to

  • get the backup on the Sony working in twrp with a sdcard
  • do full system backups
  • update CarbonROM manually, because the reboot into recovery doesn't work
  • getting a stable usb connection to the tablet by rotating ports, cables and orientations of the plugs
  • install a newer version of recovery.img on the tablet
    • needed to recap how this is done in Linux using heimdall
  • install the newer LineageOS via adb sideload

Looking back at the process I prefer much upgrading my and I need to get back to the idea of getting a to get rid of the dependency on the LineageOS tablet.

in reply to this object

This way the update works also. When a new version of is found

  • confirm to download it
  • select to install

→ Phone reboots

  • press and hold volume-down and power button

→ until twrp starts loading. It then will automatically install the downloaded update.

Note to myself:

When I want to start my Sony installed with in mode I need to to switch it off, disconnect usb and then push and hold volume-down and power together until I see starting.


  • disconnect usb
  • shutdown / switch-off the phone
  • press and hold volume-down and power button …
  • …until you see twrp booting

Don't try adb, don't try rebooting from CarbonROM into twrp - you didn't get it to work the last time you tried 😉