So I had that old and broken Sony … This is an to becoming a user.

I needed a phone with stock rom to install WhatsApp on it. Switching on and off all my old phones I found a Z3 compact - touchscreen without touch working.

I remembered that those supported USB OTG already and looked for an adaptor cable. Nope, not around anymore. Looking for informations I found that in an OTG cable one pin is is shorted to GND.

The first usb micro connector I cut open turned out to be 4 pins only (at least where the cable connects). The second one had two pins on one side and three on the other - perfect.

I spliced an OTG cable made of two old USB cables and tried it: worked, didn't work, worked, didn't work. With some fiddling I found the place where it shorted.

Having OTG working I connected a wireless USB keyboard/mouse receiver and went successfully through the initial configuration. New life to old device 🙃.

Note to myself:

When I want to start my Sony installed with in mode I need to to switch it off, disconnect usb and then push and hold volume-down and power together until I see starting.


  • disconnect usb
  • shutdown / switch-off the phone
  • press and hold volume-down and power button …
  • …until you see twrp booting

Don't try adb, don't try rebooting from CarbonROM into twrp - you didn't get it to work the last time you tried 😉